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Introduction

About a month ago a friend directed me to RobA’s ’Artistic Regional Map’ (ARM1) tutorial. I haven’t decided whether
I should thank her or throttle her, because I had things I was supposed to work on, but this was so shiny. . . .

I recommend that anyone who chooses to do artistic regional maps read RobA’s tutorial and be comfortable with
the techniques presented there. This document assumes that this is so.

RobA’s tutorial provided me with a starting set of techniques that I’ve been applying to my own maps. However,
the mountains produced by the techniques described in the ARM produce what look like very old mountains lower
and rounded, as after a lot of erosion. This is suitable for some purposes, but I like mountains that are more dramatic.

The techniques described in a linked document (the Simple Mountains tutorial) have some artifacting I don’t care
for in the bump mapping.

I’ve developed some techniques here that I think work better for me. A friend of mine saw a couple of WIP and
asked me to write a tutorial for him.

As a bit of background, I am very much a fan of semi-random techniques. I like to provide some ’guidance’ to
the processes, so I have an idea of roughly what I’ll get, but I like having the details generated for me. For instance,
I don’t mind at all using my slop’n’go islands (another tutorial, perhaps) when I’m preparing an adventure. As long
as the island is roughly the right size and shape and has a harbor and mountain I can use for the adventure, I don’t
much care where precisely they are and in fact, the randomness may provide me some unplanned opportunities.

I will try to be as complete as I can in this tutorial. Where possible I will show the main window (what the image
looks like so far), the layers and channels dialog (so you know what I’m working with), and the toolbox (so you can
see how things are configured. This may look a little tedious (and trust me, it’s more tedious to prepare it this way),
but hopefully it will make things simple and unambiguous.

Tools Used

• GIMP (http://www.gimp.org/); I am using 2.6.7 on Windows XP x64 SP2 with 4 GB of RAM, fully patched.

• MathMap (http://www.complang.tuwien.ac.at/schani/mathmap/). This is optional (you can use the Solid
Noise filter found under ’Filters→ Render→ Clouds→ Solid Noise’). The Solid Noise filter in GIMP seems to
show some artifacting (I see what looks like ’scratch marks’ running from the top right to the bottom left). The
MathMap filters can be found under ’Filters → Generic → MathMap’. I will be using the Fractal Noise filter
found at ’Filters→ Generic→ MathMap→ Render→ Fractal Noise’.

1The parallel with the C++ Annotated Reference Manual (ARM) tickles me; all C++ programmers should read and be familiar with this
beast. Similarly, I think anyone who wants to use GIMP for artistic regional maps should read and be familiar with RobA’s tutorial.
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Step 1: New File
• Start GIMP.

• Create a new file. Mine is 428x428 (because that fits my netbook’s screen well; when I experiment on my work-
station at home I use 1284x1284, and I use 2400x3000 when I do an image intended for full-page printing).

New File



Step 2: Set Background Color
Setting the background color to a medium green will let us see approximately what the mountains may look like

on ‘green land’, including how the colors blend. I’m using color HSV (74, 52, 41) here.

• Click on the foreground color in the toolbox.

• Enter the HSV values in the color selector.

• Click and drag the ‘Current’ color to the thumbnail in the Layers dialog. This will change the layer color.

• Cancel the color selector; we don’t actually want to change the foreground color from black.

Set Background Color



Step 3: Add Black Layer
Add a black layer, to be used to mark the region you want mountains to appear in.

• Right-click on the Background layer, select ‘New Layer’.

• Fill in the dialog that appears as indicated here – Layer name is ‘mountain area’, Width and Height are as the
full image, and Layer Fill Type is ‘Foreground color’.

• Click the ‘OK’ button.

Add Black Layer



Step 4: Draw Mountain Area
Draw the region you want to have mountains appear in. I prefer to use the Pencil tool with my tablet, with jitter

set to 1.0. I have found that irregularly-shaped regions tend to produce better results.

• Ensure the ‘mountain area’ layer is selected.

• Select the Pencil tool, swap the foreground and background colors, turn off Brush Dynamics (you want a solid
white brush), select ‘Apply Jitter’ and set amount to 1.00 (see screenshot below).

• Draw outlines of regions to have mountains, and fill them.

I found after completing this tutorial (actually, by Step 9) that the ‘legs’ I put around the mountains more or less
disappeared. They were too light compared to the main ‘mountains’. Making them thicker (or making the ‘mountains’
smaller) would probably have kept them around.

Draw Mountain Area



Step 5: Blur Mountain Area
We want to blur the edges of the mountainous areas because we are using RobA’s ‘Three Layer Sandwich’ (TLS)

technique here to make the mountain areas less regular.

• Start the Gaussian Blur filter (Filters→ Blur→ Gaussian Blur).

• Set to Blur Radius to 50 pixels both horizontally and vertically (I often use more, but this is a small image and
I’m close to the edges).

• Click the ‘OK’ button.

Blur Mountain Area



Step 6: Add White Layer
Add a white layer that will be filled with noise.

• Right-click on the ‘mountain area’ layer, select ‘New Layer’.

• Fill in the dialog that appears as indicated here – Layer name is ‘mountain noise’, Width and Height are as the
full image, and Layer Fill Type is ‘Foreground color’.

• Click the ‘OK’ button.

Add White Layer



Step 7: Fill Noise Layer
Populate the ‘mountain noise’ layer with fractal noise (Filters→ Generic→MathMap→ Render→ Fractal Noise),

or solid noise (Filters→ Render→ Clouds→ Solid Noise) if you prefer. I’m using fractal noise.

• Ensure the ‘mountain noise’ layer is selected.

• Start the Fractal Noise filter (Filters → Generic → MathMap → Render → Fractal Noise). For now, accept all
the default values (explore those another time).

• Click the ‘OK’ button.

• Set Layer Mode to ‘Multiply’ (Overlay also works, Multiply is a little more aggressive).

Fill Noise Layer



Step 8: Add White Layer
Add a white layer that will be used to filter out ‘non-mountain’ area.

• Right-click on the ‘mountain noise’ layer, select ‘New Layer’.

• Fill in the dialog that appears as indicated here – Layer name is ‘mountain filter’, Width and Height are as the
full image, and Layer Fill Type is ‘Foreground color’.

• Click the ‘OK’ button.

• Set layer mode to ‘Lighten only’.

Add White Layer



Step 9: Adjust Filter Color
Lowering the white value of the filter layer will cause low-value regions of the underlying image to be replaced

with the white value of the filter layer. This will make it easy to select the mountains.

• Ensure the ‘mountain filter’ layer is selected.

• Select the Color Curves tool (could also use Levels, I prefer Curves).

• Adjust the curve until you can see the regions you want to have mountainous. I usually find this to be around
the second line up on the right-hand side, as shown here.

• Click the ‘OK’ button.

Adjust Filter Color



Step 10: Select Mountains
Now to select the regions to actually get mountains drawn in. This is a longer one than usual.

• Select the Fuzzy Select tool (’magic wand’). Ensure that ‘Sample Merged’ is checked (shown below).

• Click on the darker part of the image, where the mountains aren’t.

• Invert the selection (Ctrl-I, or Select→ Invert).

• Feather the selection (Select→ Feather; accept the default of 5 pixels). This will be important later.

Select Mountains



Step 11: Store Mountain Selection
Let’s save this selection before something silly happens. We did a lot of work to get here (in reality, I usually hit

this point within a couple of minutes of starting, but no sense losing it).

• Save to channel (Select→ Save to Channel).

• Rename channel to ‘mountain mask’ (you’ll want this later).

Store Mountain Selection



Step 12: Create Mountain Ridge Layer
Add a layer that will be a gross height map for the mountains’ ridge.

• Right-click on the ‘mountain filter’ layer, select ‘New Layer’.

• Fill in the dialog that appears as indicated here (as previous new layers, but use the background color – we
want a black layer) and click the ‘OK’ button.

• You will now have a black layer with a selection. Select the ‘Gradient Fill’ tool using the ‘Shaped (angular)’
shape and drag a short line inside the selection.

• Clear the selection (Shift-Ctrl-A, or Select→ None).

Create Mountain Ridge Layer



Step 13: Soften Ridges
I see some nice ridges here, but there is some artifacting from the angular fill, and some irregularities caused by

the selection used. Let’s soften these a bit.

• Add noise by selecting the Spread filter (Filter → Noise → Spread). Accept the default of 5 pixels spread (I
often increase this to as much as 10).

• Now apply a slight Gaussian Blur (Filters → Blur → Gaussian Blur). This time I’m reducing it to a five-pixel
blur radius, sometimes I use as much as 10 or 15.

Soften Ridges



Step 14: Build High Height Map
Believe it or not, we’re more than halfway there. We need to create a couple of height maps to finish this off.
First let’s create the ‘high height map’, which will be used for the peaks.

• Move the ‘mountain noise’ layer to the top of the stack. It will still have a layer mode of ‘Multiply’.

• Add a new layer from visible as shown below, and rename to ‘high height map’.

• Duplicate this layer twice, renaming the first to ‘snow caps’ and the second to ‘mountain color’.

• Turn off all three new layers.

Build High Height Map



Step 15: Build Low Height Map
Now for the ‘low height map’, which will provide the build of the mountain bump map.

• Select the ‘mountain noise’ layer and set the layer mode to ‘Overlay’.

• Create new layer from visible, rename it to ‘low height map’.

Build High Height Map



Step 16: Add Bump Map Layers
Create two medium gray layers to be used for bump maps. These bump maps will provide the pop that makes

the mountains stand out.

• Select medium gray (click on the foreground color in the toolbox, select HSV (0, 0, 50). Do not click ‘OK’.

• Right-click on the ‘snow caps’ layer and select ‘New Layer’.

• Populate the dialog as shown below (name of ‘low bump map’, use the foreground color) and click the ‘OK’
button.

• Cancel the color selector; we don’t actually want to change the foreground color right now.

• Duplicate the new layer and call it ‘high bump map’.

Add Bump Map Layers



Step 17: Build Low Bump Map
Now to create the bump map that will provide most of the shape for the mountains.

• Turn off all layers except the ‘low bump map’ and ‘Background’ layers, and select the ‘low bump map’ layer.

• Apply a linear Bump Map (Filters → Map → Bump Map). Use the ‘low height map’ layer as the bump map,
‘Linear’ map type. Let’s make this a moderately aggressive bump map; set the depth to 15.

Build Low Bump Map



Step 18: Build High Bump Map
Now the bump map that makes the peaks pop.

• Select and make visible the ‘high bump map’ layer.

• Apply a sinusoidal bump map (Filters→ Map→ Bump Map, or Shift-Ctrl-F to reshow Bump Map). This time,
use the ‘high height map’ and ‘Sinusoidal’ map type. Let’s be a little more aggressive this time and set the depth
to 30.

Build High Bump Map



Step 19: Preview Bump Maps
Let’s see what the mountains really look like. We won’t have color yet, but we can get a clear view of the shape

of them.

• Set the mode of both bump map layers (’high bump map’ and ‘low bump map’) to ‘Overlay’.

Preview Bump Maps



Step 20: Prepare Mountain Color Layer
Now we’re down to finishing touches. Let’s get some color on the mountains.

• Select the ‘mountain color’ layer and make it visible.

• Add a layer mask to this layer. Right click on the layer and select ‘Add Layer Mask’.

• Initialize the layer mask to the ‘mountain mask’ channel and click the ‘Add’ button.

Prepare Mountain Color Layer



Step 21: Blend Mountain Color Layer
There is a very harsh transition between the color layer and the background. Let’s fix that before moving on.

• Ensure the layer mask associated with the ‘mountain color’ layer is selected (it should still be, we just added
it).

• Apply a Gaussian Blur (Filters → Blur → Gaussian Blur). I tend to use a radius of about 20 (15-25). In this
case I’ve gone up to 25.

Blend Mountain Color Layer



Step 22: Set Mountain Color Gradient
Almost done. Thank gods.

• Select the ‘mountain color’ layer.

• Set the foreground color to a medium brown. I’m using HSV (27, 64, 38).

• Set the background color to a light gray. I’m using HSV (0, 0, 80).

• Map the layer’s colors to the gradient defined by these colors (Colors→ Map→ Gradient Map).

Set Mountain Color Gradient



Step 23: Just Add Snow
These mountains already show a bit of white on top, but let’s add a bit of explicit ‘snow’. I usually don’t, I like

just the hint provided here, but I’ll show you a way to do it.

• Select and make visible the ‘snow caps’ layer (ha! Bet you were wondering why we did that).

• Set the ‘snow caps’ layer to ‘Screen’ mode.

• This is a little too bright yet. Adjust the color curve (Colors → Curves). Usually somewhere between the first
and third horizontal line is about right.

Just Add Snow



Final Notes

With a bit of practice, this is a pretty quick process. It took me about four or five hours to document it (I’ve got a
cold). Normally I could create an image like this in five to ten minutes.

These mountains are perhaps not quite as right as they could be. They look to me like they are awfully flat for how
pointy they are. Jagged peaks are usually a sign of relatively recent geological activity, but these mountains seem
wide for their height. Turning off the ‘high bump map’ layer makes these mountains look more reasonable to me. I
usually have my mountains ‘narrower’, where jagged peaks look more appropriate. This might also be correctable by
more aggressive bumpmapping – ad hoc tripling of the ‘low bump map’ layer, doubling of the ‘high bump map’ layer,
and doubling of the ‘snow caps’ layer suggests this may be viable, but they’re looking sharp and almost blown out. I
prefer to soften them and call them ‘old mountains’ instead.

I used the ‘high height map’ for my mountain color layer because I prefer to limit how much ‘high ground’ I have
in the mountains. Using the ‘low height map’ increases amount of high color in the mountains. It’s hit and miss,
really, and worth trying both.

Apart from that, I’m fairly pleased with how this works. I have visible ridges in these mountains, minimal
undesirable artifacting. As I said, in this case I think I’ve got some inappropriate jaggedness for the mountain width,
but that’s pretty easily removed.

Any thoughts, questions, or comments on this process? I’m sure there is lots of room for improvement, but I hope
this will help others in their quest for pretty maps.

Keith
mailto:keith.davies@kjdavies.org
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